%> DRAWLINE函数高成功率指标背后的制造者_教育巴巴炒股教程网
DRAWLINE函数高成功率指标背后的制造者 2235

一直以来都有很多的指标号称高成功率,且用未来函数检测工具检查,结果没有任何未来函数。

面对这样的指标,众多股市新手如获至宝,可是实际操作起来却屡屡受挫,信号常常发生偏移!

我检查了较多的高成功率的指标,发现它们基本都有一个特性:含有函数DRAWLINE()。

早有前辈早已指出:DRAWLINE只是图形上绘制直线段函数,不是未来函数。这个说法没有错,DRAWLINE()本身姿势图形绘制直线段函数,不是未来函数。


那么,问题出在哪儿呢?

问题在于把DRAWLINE返回值赋值给某变量。如ABC:DRAWLINE(HIGH>=HHV(HIGH,20),HIGH,LOW<=LLV(LOW,20),LOW,0);


首先要说明的是,DRAWLINE(COND1,PRICE1,COND2,PRICE2,EXPAND)函数画线有个特色,COND1常常成立,但是只有COND2成立后才画出线段。


ABC:DRAWLINE这条赋值语句呢,在COND2未成立时,赋值是空的,但是如果后面COND2成立了,ABC就被赋值了,此时信号将发生偏移。

这种特性完全就是未来函数!


最常见的主图名称就是:区间买卖,魔鬼通道等等名字,问题就出现在以下的划线代码中:


N1:=7;

LC:=REF(CLOSE,1);

X:=SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100,COLORYELLOW,LINETHICK1;

魔鬼:=DRAWLINE(X>=HHV(X,N1),X,X<=LLV(X,N1),X,1),COLOR00FF00;

魔王:=DRAWLINE(X>=HHV(X,N1),X,X<=LLV(X,N1),1,X),COLOR00FF00;

TJ0:=X=魔王;

TJ1:=X=魔鬼;

TJ2:=X<REF(X,1);

TJ3:=X>REF(1,X);

JRS1:=DRAWICON(TJ1 AND TJ2,X,1);

JRS2:=DRAWICON(TJ0 AND TJ3,X,2);

DRAWICON(FILTER(JRS1>0,1),L*0.97,1);

DRAWICON(FILTER(JRS2>0,1),H*1.02,15);




以上的代码如果对照历史,成功率可以达到100%,并且100%是买在最低价,卖在最高价!如果真的这样,你家比国库的钱都多了!所以大家可以检查一下你使用的指标中是否含有以上类似的划线代码,有的话你可以在实战中看看,昨天下跌,信号就出现在昨天,今天下跌,信号就出现在今天,明天下跌,信号就出现在明天!

{股票教程网-http://9188edu.com指标公式,仅供学习研究,参考价值,请勿以此为依据进行交易!}