大智慧KDJ的MACD指标公式

返回列表
大智慧公式 1077
公式说明

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

K:=SMA(RSV,3,1);

D:=SMA(K,3,1);

J:=3*K-2*D;

DIFF:EMA(J,8) - EMA(J,16),COLOR00FF00,LAYER0;;

DEA:EMA(DIFF,5),COLORFF9900,LAYER0;;

MACD:2*(DIFF-DEA), COLORSTICK;;

0,COLORff9900,DOTLINE;

FILLRGN(DIFF,DEA,DIFF>DEA,RGB(80,0,80),DIFF<DEA,RGB(0,120,60)),LAYER7;

TYP:FORCAST(((2*C+H+L)/4*0.618+C*0.382),3),color00FFFF,linethick0;{FORCAST}

AAX:=(TYP-ma(TYP,9))/ma(TYP,9)*100;

VARM:=MIN(COUNT(TYP,0),9);

AAX1:=EMA(AAX,VARM) *VARM;

AAX2:=MA(AAX1,3);

AAX3:=MA(AAX1,5);

卖:AAX3>10 AND AAX1<REF(AAX1,1) AND CROSS(AAX2,AAX1),linethick0;

减仓:filter(卖,5) ,PRECIS0,linethick0;

VERTLINE(减仓>0,2),LAYER0,COLOR00ffFF;

drawtext(减仓,10*1.6,'◆'),ALIGN2,colorcyan;

drawtext(减仓,10*1.5,'◇'),ALIGN1,color00FF00;

drawtext(减仓,10*1.59,'◆'),ALIGN0,colorcyan;

DRAWTEXTABS(5,5,'■现在KDJ的参数是:N=9,M1=3,M2=3;'),COLOR00FFFF,LINETHICK3,LAYER0;

DRAWTEXTABS(5,25,'■【KDJ】的【MACD】的参数是:LONG=8,LONG=16,M=5;'),COLOR0099FF,LINETHICK3,LAYER0;



 

点击下载大智慧公式调试用软件>>
赞赏本站

如果本站对您有所帮助,请打开您的微信,扫一扫下面的二维码,赞助本站,金额随意

算是您支持我们的发展,和对我们工作努力的肯定!小编在些表示感谢!


weix.jpg


联系客服:
客服 客服2
返回课程列表