通达信条件预警的全面设置

Class:公式教程 Time:2019-9-19 Hits:913

一、一般情况下的设置。


1打开预警设置框。在通达信程序的右下角点击两个三角的地方。





2.条件预警框出现。





3.点击条件预警框下面的设置。在出现的设置对话框中,点击“添加股票”可以添加你需要预警的股票,可以选择处个板块导入。





4.点击“公式设置”选项卡,如下图。点击添加公式。





5.出现公式条件预警设置,在选股公式的下拉菜单中,选择合适的公式。





6.可以看出这里面的公式,都是条件选股公式。没有其他类型的如技术指标公式。





7.可以根据自己的要求多选择几个公式,但要注意的是预警时,只要满足其中一个条件就会预警,而不是同时全部满足时预警。





8.点击条件预警设置中的其它设置选项卡,可以设置预警的声音。



9.点击确定后退出,好了只要条件达到,通达信就会给你预警了。


二、多条件同时预警。


上面已经说了,在预警时虽然选择了多个条件,但只要其中一个条件达到要求,就会预警,而有时我们需要同时满足两个条件时才预警,那怎么办呢?


这就需要借助通达信的公式编辑器了。按ctrl+F运行公式编辑器,把你需要的两个公式都通过修改的方式粘贴出来,再新建一个公式,把它们合并起来,但最后设置满足条件时,要把这两个公式结尾部分的条件用and连接起来,保存后,再到预警中设置就行了。


如连续N 日收阳的公式


{N为参数:1:10:100)}


UP3:= UPNDAY(CLOSE,N));


与macd线买入


DIFF := EMA(CLOSE,SHORT) - EMA(CLOSE,LONG);

DEA := EMA(DIFF,M);

CROSS(DIFF,DEA);


你合成时,就写成


UP3:= UPNDAY(CLOSE,N));


DIFF := EMA(CLOSE,SHORT) - EMA(CLOSE,LONG);

DEA := EMA(DIFF,M);

UP3 and CROSS(DIFF,DEA);


就行了,注意最后一句。


三、对于其它非条件选股(包括副图的一样指标公式)的公式如技术指标选股的公式,与上面一样,也应该进入公式编辑器中,把这个技术指标公式改编为条件选股公式才可以使用。


如副图中“主力散记筹码线”公式。


原公式是:


VAR1:=1;

VAR2:=1/WINNER(CLOSE);

VAR3:=MA(CLOSE,13);

VAR4:=100-ABS((CLOSE-VAR3)/VAR3*100);

VAR5:=LLV(LOW,75);

VAR6:=HHV(HIGH,75);

VAR7:=(VAR6-VAR5)/100;

VAR8:=SMA((CLOSE-VAR5)/VAR7,20,1);

VAR9:=SMA((OPEN-VAR5)/VAR7,20,1);

VARA:=3*VAR8-2*SMA(VAR8,15,1);

VARB:=3*VAR9-2*SMA(VAR9,15,1);

VARC:=100-VARB;

主力: (100-VARA)*VAR1,COLOR0099FF;

散户: MA(WINNER(CLOSE*0.95)*100,3)*VAR1,COLORYELLOW;

新庄: (100-IF(VAR2>5,IF(VAR2<100,VAR2,VAR4-10),0))*VAR1,COLORGREEN,LINETHICK1,POINTDOT ;

VARD:=散户>VAR4;

VARE:=REF(LOW,1)*0.9;

VARF:=LOW*0.9;

VAR10:=(VARF*VOL+VARE*(CAPITAL-VOL))/CAPITAL;

VAR11:=EMA(VAR10,30);

VAR12:=CLOSE-REF(CLOSE,1);

VAR13:=MAX(VAR12,0);

VAR14:=ABS(VAR12);

VAR15:=SMA(VAR13,7,1)/SMA(VAR14,7,1)*100;

VAR16:=SMA(VAR13,13,1)/SMA(VAR14,13,1)*100;

VAR17:=BARSCOUNT(CLOSE);

VAR18:=SMA(MAX(VAR12,0),6,1)/SMA(ABS(VAR12),6,1)*100;

VAR19:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;

VAR1A:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;

VAR1B:=SMA((SMA(VAR1A,4,1)-50)*2,3,1);

VAR1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;

VAR1D:=SMA(VAR1C,4,1);

VAR1E:=SMA(VAR1D,3,1);

VAR1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;

VAR20:=VAR18<=25 AND VAR19<-95 AND VAR1F>20 AND VAR1B<-30 AND VAR1E<30 AND VAR11-CLOSE>=-0.25 AND VAR15<22 AND VAR16<28 AND VAR17>50;

STICKLINE(VARD,VAR4,散户,5,0),COLORWHITE;

STICKLINE(1,新庄,100,1,0),COLORGREEN;

STICKLINE(VAR20,0,80,5,0),COLORRED,LINETHICK3 ;

100,COLORGREEN ,LINETHICK2 ;

0,COLORYELLOW ,LINETHICK2 ;

中线: 15,COLORBLUE ,LINETHICK2 ;


根据使用这的情况得知,当主力线逐渐下移进,该股就会开始拉升,形势变好。为此可以把这个公式改编成这样一个条件选股公式。


VAR1:=1;

VAR2:=1/WINNER(CLOSE);

VAR3:=MA(CLOSE,13);

VAR4:=100-ABS((CLOSE-VAR3)/VAR3*100);

VAR5:=LLV(LOW,75);

VAR6:=HHV(HIGH,75);

VAR7:=(VAR6-VAR5)/100;

VAR8:=SMA((CLOSE-VAR5)/VAR7,20,1);

VAR9:=SMA((OPEN-VAR5)/VAR7,20,1);

VARA:=3*VAR8-2*SMA(VAR8,15,1);

VARB:=3*VAR9-2*SMA(VAR9,15,1);

VARC:=100-VARB;

主力:=(100-VARA)*VAR1;

EVERY(主力


很明显,因为不需要画线,也不需要其它函数,所以我只用了原公式中前半部分(蓝色字体的部分),而修改的也只有后面一句(改编后的红色字体部分),又加上了一句用来判断的语句。


保存后就可以在条件预警中使用了。

{教育巴巴炒股教程网,http://9188edu.com,友情提供}
股票教程网所有股票公式,仅供学习研究,只有参考价值,请勿以此为依据进行股票交易!

本站所有公式全部免费,如果这条公式对您有价值,或有帮助,请打开微信,扫一扫下面的二维码,赞助本站,金额随意!

感谢您对支持我们的发展和对我们工作的肯定!小编在些表示感谢!

本站提供通达信指标破解:普通加密破解、完全加密破解、指标导入密码破解指标公式编写,指标修改,指标DLL加密等业务,详询客服!