同花顺趋势上涨指标公式

Class:同花顺公式 Time:2019-9-19 Hits:892

//{1.机构部分}

买线:=ZIG(3,10);

卖线:=MA(买线,2);

BU:=CROSS(买线,卖线);

SEL:=CROSS(卖线,买线);

DRAWTEXT(BU,L*0.95,'机构进场'),coloryellow;

DRAWTEXT(SEL,H*1.05,'机构清仓'),colorgreen;

STICKLINE(买线>=卖线,LOW,HIGH,0,0),colorred;

STICKLINE(买线>=卖线,CLOSE,OPEN,2,0),colorred;

STICKLINE(买线<卖线,CLOSE,OPEN,2,0),colorgreen;

STICKLINE(买线<卖线,LOW,HIGH,0,0),colorgreen;

STICKLINE(CROSS(买线,卖线),OPEN,CLOSE,2,0),coloryellow;

STICKLINE(CROSS(卖线,买线),OPEN,CLOSE,2,0),colorblue;

DRAWICON((ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2)) AND(REF(ZIG(3,5),2)<=REF(ZIG(3,5),3)),LOW*0.99,1);

DRAWICON((ZIG(3,5)=REF(ZIG(3,5),2)) AND(REF(ZIG(3,5),2)>=REF(ZIG(3,5),3)),H,2);

//{2.买卖}

VARC:=(ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2)) AND(REF(ZIG(3,5),2)<=REF(ZIG(3,5),3));

VARD:=(ZIG(3,5)=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)>=REF(ZIG(3,5),3));

DRAWTEXT((VARC=1),L,'买'),coloryellow;

DRAWTEXT((VARD=1),H,'卖'),colorblue;

//{3.头部}

V10:=PEAKBARS(3,15,1)<10;

V12:=IF(V10=1,50,0);

头部:= IF(V12=50,100,0);

DRAWTEXT(头部>REF(头部,1),H*1.02,'减仓'),colorwhite,LINETHICK1;

//{4.抄底}

V9:=TROUGHBARS(3,15,1)<10;

V11:=IF(V9=1,50,0);

DRAWTEXT(V11>REF(V11,1),L*0.95,'抄底'),colormagenta;

//{5.短线}

VARE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;

VARF:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA

((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);

VAR10:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA

((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);

VAR11:=VARF<REF(VAR10,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);

DRAWTEXT(VAR11 AND COUNT(VAR11,30)=1,L*0.95,'B'),colorlimagenta;

VAR12:=(HIGH+LOW+CLOSE)/3;

VAR13:=(VAR12-MA(VAR12,14))/(0.015*AVEDEV(VAR12,14));

VAR14:=(VAR12-MA(VAR12,70))/(0.015*AVEDEV(VAR12,70));

VAR15:=IF(VAR13>=150 AND VAR13<200 AND VAR14>=150 AND VAR14<200,10,0);

VAR16:=IF(VAR13<=-150 AND VAR13>-200 AND VAR14<=-150 AND VAR14>-200,-10,VAR15);

VAR17:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;

VAR18:=100-ABS(VAR17);

VAR19:=IF(VAR18<90,VAR18,100);

VAR1A:=IF(VARE>0,VARE,0);

VAR1B:=IF(VAR14>=200 AND VAR13>=150,15,IF(VAR14<=-200 AND VAR13<=-150,-15,VAR16))+60;

VAR1C:=VAR1A>48 AND VAR1B>60 AND VAR19<100;

DRAWTEXT(VAR1C AND COUNT(VAR1C,30)=1,H*1.05,'S'),colorgreen;

//{6.基金部分}

VRE2:=REF(LOW,1)*0.9;

VRF2:=LOW*0.9;

VR10:=(VRF2*VOL+VRE2*(CAPITAL-VOL))/CAPITAL;

VR11:=EMA(VR10,30);

VR12:=CLOSE-REF(CLOSE,1);

VR13:=MAX(VR12,0);

VR14:=ABS(VR12);

VR15:=SMA(VR13,7,1)/SMA(VR14,7,1)*100;

VR16:=SMA(VR13,13,1)/SMA(VR14,13,1)*100;

VR17:=BARSCOUNT(CLOSE);

VR18:=SMA(MAX(VR12,0),6,1)/SMA(ABS(VR12),6,1)*100;

VR19:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;

VR1A:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;

VR1B:=SMA((SMA(VR1A,4,1)-50)*2,3,1);

VR1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;

VR1D:=SMA(VR1C,4,1);

VR1E:=SMA(VR1D,3,1);

VR1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;

VR20:=VR18<=25 AND VR19<-95 AND VR1F>20 AND VR1B<-30 AND VR1E<30 AND VR11-CLOSE>=-0.25 AND VR15<22 AND VR16<28 AND VR17>50;

VR21:=(HIGH+LOW+CLOSE)/3;

VR22:=(VR21-MA(VR21,14))/(0.015*AVEDEV(VR21,14));

VR23:=(VR21-MA(VR21,70))/(0.015*AVEDEV(VR21,70));

VR24:=VR22>=150 AND VR22<200 AND VR23>=150 AND VR23<200;

DRAWTEXT(VR20 AND COUNT(VR20,1)=1,H*0.99,'建仓'),colormagenta;

DRAWTEXT(VR24 AND COUNT(VR24,1)=1,L*1.1,'清仓'),colorblue;



 

{教育巴巴炒股教程网,http://9188edu.com,友情提供}
股票教程网所有股票公式,仅供学习研究,只有参考价值,请勿以此为依据进行股票交易!

本站所有公式全部免费,如果这条公式对您有价值,或有帮助,请打开微信,扫一扫下面的二维码,赞助本站,金额随意!

感谢您对支持我们的发展和对我们工作的肯定!小编在些表示感谢!

本站提供通达信指标破解:普通加密破解、完全加密破解、指标导入密码破解指标公式编写,指标修改,指标DLL加密等业务,详询客服!