大智慧黄蓝阶梯主图指标公式

返回列表
热搜课程: 益盟高级课 量学 黑马王子 淘股吧教程 老马点金 缠论 月风先生教程 伍朝辉 唐能通股票教程 财富讲坛股市108将 Python量化交易 爱股轩股票教程 缠中说禅 长投学堂
大智慧公式 关注:1746
公式说明

N1:=5;

N2:=20;

JJ:=(CLOSE+HIGH+LOW)/3;

A:=EMA(JJ,10);

B:=REF(A,1);

ma5:ma(c,n1);

ma20:=ma(c,n2);

{MA6:MA(CLOSE,P4),linethick2,colorCC9900;

MA7:MA(CLOSE,P5),linethick2;

MA8:MA(CLOSE,P6),linethick2,colorcyan;}

STICKLINE(A>B,A,B,9,0),COLOR0099FF{colorgreen};

STICKLINE(A<B,A,B,9,0),COLORBLUE;

买入:cross(a,b),LINETHICK0;

买入天数:last(a>b),LINETHICK0;

{=====================================}

DRAWTEXTABS(2,6,'所属板块:'+BKNAME),COLORblack,linethick1;

每股净资产:=FINANCE2(4);

销售毛利率:=FINANCE2(12);

主营收入同比:=FINANCE2(11);

净利润同比:=FINANCE2(10);

DRAWTEXTABS(118,21,'每股净资产:'+NUMTOSTRN(每股净资产,2)+'元'),COLORRED;

DRAWTEXTABS(2,21,'销售毛利率:'+NUMTOSTRN(销售毛利率,2)+'%'),LINETHICK1,COLORblue;

DRAWTEXTABS(2,39,'主营收入同比:'+NUMTOSTRN(主营收入同比,2)+'%'),LINETHICK1,Colorblack;

DRAWTEXTABS(2,54,'净利润同比:'+NUMTOSTRN(净利润同比,2)+'%'),LINETHICK1,COLOR006633;

DRAWTEXTABS(3,69,'最高价:'+HHV(HIGH,0)),Colorred;

DRAWTEXTABS(3,84,'最低价:'+LLV(LOW,0)),Colorff0099;

{******************************}

VAR1:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));

VAR2:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));

SK:= EMA(Var1,13)-EMA(Var1,73);

SD:= EMA(SK,2);

drawtext((cross(sk,sd) and sk<-0.04 and (c-ref(c,1))/ref(c,1)>=0.03) or (cross(sk,sd) and sk<=-0.14 )

or (cross(sk,sd) and sk<=0.05 and (v/ma(v,5)>2 or c/ref(c,1)>0.035)) ,l*0.99,'短线'),colorff0099;

stickline((cross(sk,sd) and sk<-0.04 and (c-ref(c,1))/ref(c,1)>=0.03) or (cross(sk,sd) and sk<=-0.14 )

or (cross(sk,sd) and sk<=0.05 and (v/ma(v,5)>2 or c/ref(c,1)>0.035)),h,l,0.5,0),colorred;

stickline((cross(sk,sd) and sk<-0.04 and (c-ref(c,1))/ref(c,1)>=0.03) or (cross(sk,sd) and sk<=-0.14 )

or (cross(sk,sd) and sk<=0.05 and (v/ma(v,5)>2 or c/ref(c,1)>0.035)),o,c,10,1),linethick3,colorred;

{===================================================================}

{将上面的源码复制粘贴到任意主图即可};

DA:=6;FA:=5;CT:=1;P:=0;N:=3;

MM:=IF(((P=0) OR (VOL=0)),MA(CLOSE,N1),((SUM(AMOUNT,N1)/SUM(VOL,N1))/100));

M1:=REF(MM,1);

买入:=IF(CROSS(CLOSE,M1),M1,0);

卖出:=IF(CROSS(M1,CLOSE),M1,0);

DW:=BARSLAST((卖出>0));

EX10:=HHV((买入>0),(DW+1));

BJ:=IF((EX10>REF(EX10,1)),买入,0);

SJ:=IF((EX10<REF(EX10,1)),卖出,0);

STICKLINE(BJ>0 AND CT=1,OPEN,(CLOSE+OPEN)/2,5.28,0), COLOR0044FF;

STICKLINE(BJ>0 AND CT=1,OPEN,(CLOSE+OPEN)/2,2.6,0), COLOR0077FF;

STICKLINE(BJ>0 AND CT=1,OPEN,(CLOSE+OPEN)/2,2.2,0), COLOR1199FF;

STICKLINE(BJ>0 AND CT=1,OPEN,(CLOSE+OPEN)/2,1.8,0), COLOR22BBFF;

STICKLINE(BJ>0 AND CT=1,OPEN,(CLOSE+OPEN)/2,1.4,0), COLOR33DDFF;

STICKLINE(BJ>0 AND CT=1,OPEN,(CLOSE+OPEN)/2,1,0), COLOR33FFFF;

STICKLINE(BJ>0 AND CT=1,CLOSE,(CLOSE+OPEN)/2,3,0), COLOR000055;

STICKLINE(BJ>0 AND CT=1,CLOSE,(CLOSE+OPEN)/2,2.6,0), COLOR000077;

STICKLINE(BJ>0 AND CT=1,CLOSE,(CLOSE+OPEN)/2,2.2,0), COLOR000099;

STICKLINE(BJ>0 AND CT=1,CLOSE,(CLOSE+OPEN)/2,1.8,0), COLOR0000BB;

STICKLINE(BJ>0 AND CT=1,CLOSE,(CLOSE+OPEN)/2,1.4,0), COLOR0000DD;

STICKLINE(BJ>0 AND CT=1,CLOSE,(CLOSE+OPEN)/2,1,0), COLOR0033FF;

STICKLINE(((SJ>0) AND (CT=1)),CLOSE,(CLOSE+OPEN)/2,5.580,0),COLORFF4400;

STICKLINE(((SJ>0) AND (CT=1)),CLOSE,(CLOSE+OPEN)/2,2.6,0),COLORFF7700;

STICKLINE(((SJ>0) AND (CT=1)),CLOSE,(CLOSE+OPEN)/2,2.2,0),COLORFF9911;

STICKLINE(((SJ>0) AND (CT=1)),CLOSE,(CLOSE+OPEN)/2,1.8,0),COLORFFBB22;

STICKLINE(((SJ>0) AND (CT=1)),CLOSE,(CLOSE+OPEN)/2,1.4,0),COLORFFDD33;

STICKLINE(((SJ>0) AND (CT=1)),CLOSE,(CLOSE+OPEN)/2,1,0),COLORFFFF33;

STICKLINE(((SJ>0) AND (CT=1)),OPEN,(CLOSE+OPEN)/2,3.0,0),COLOR550000;

STICKLINE(((SJ>0) AND (CT=1)),OPEN,(CLOSE+OPEN)/2,2.6,0),COLOR770000;

STICKLINE(((SJ>0) AND (CT=1)),OPEN,(CLOSE+OPEN)/2,2.2,0),COLOR990000;

STICKLINE(((SJ>0) AND (CT=1)),OPEN,(CLOSE+OPEN)/2,1.8,0),COLORBB0000;

STICKLINE(((SJ>0) AND (CT=1)),OPEN,(CLOSE+OPEN)/2,1.4,0),COLORDD0000;

STICKLINE(((SJ>0) AND (CT=1)),OPEN,(CLOSE+OPEN)/2,1,0),COLORFF0000;

{分仓管理}{主图叠加}{大智慧L2公式macd}

q1:=(IF(DATE > 1341231,0,1));

a43:=(q1 * (BARSLAST(DISPSTATUS = 1) + 1));

a44:=(LLVALL(LLV(L,a43)));

a65:=(TROUGHBARS(3,15,1) < 4);

a66:=(EMA((C - MA((2 * C + H + L) / 4,30)) / MA((2 * C + H + L) / 4,30) * 100,3));

a67:=(FILTER(a65 = 1,5));

a68:=(FILTER(a65 = 1,5) and a66 < -10);

a69:=(FILTER(a65 = 1,3));

DRAWTEXT(REF(a69,1) = 0 and REF(a69,2) = 1,a44 * 0.99,'★'),linethick5,VALIGN2,ALIGN1,ColorFF9900;

{====================================}

AR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);

DRAWTEXT(AR13,c*0.958,'●'), COLORRED;

AR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);

DRAWTEXT(AR17,c*0.958,' 发现黑马'), COLORBROWN;

{********************************}

A5:=EMA(CLOSE,12)-EMA(CLOSE,26);

A6:=EMA(A5,9);

A7:=(A5<-0.1 AND A5>A6);

龙王:IF(A7,LLV(L,21),ma20),{COLOR888888,CIRCLEDOT}POINTDOT,COLORred,LINETHICK3;

;{将上面的源码复制粘贴到任意主图即可};

PARTLINE(ma20,ma20>ref(ma20,1),RGB(255,0,0),ma20<ref(ma20,1 ),RGB(0,255,0)),LINETHICK2;

{========================================================================}

{火眼金睛}

上:=(SMA(HIGH,21,2) * 1.05);

下轨道:=(SMA(LOW,21,2) * 0.969);

RSV:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100);

K:=SMA(RSV,3,1);

D:=SMA(K,3,1);

J:=((3 * K) - (2 * D));

RSV24:=(((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100);

K24:=SMA(RSV24,3,1);

D24:=SMA(K24,3,1);

J24:=((3 * K24) - (2 * D24));

支撑位:=IF(CROSS(J,J24),LOW,REF(LOW,BARSLAST(CROSS(J,J24))));

压力位:=IF(CROSS(J24,J),HIGH,REF(HIGH,BARSLAST(CROSS(J24,J))));

L2L:=IF((CLOSE >= MA(CLOSE,20)),50,20);

RL1:=IF(((J > L2L) AND (REF(J,1) <= L2L)),LLV(REF(LOW,1),(BARSLAST(((J <= L2L) AND (REF(J,1) > L2L))) - 1)),REF(LLV(REF(LOW,1),(BARSLAST(((J <= L2L) AND (REF(J,1) > L2L))) - 1)),BARSLAST(((J > L2L) AND REF(J,1)))));

RL4:=IF((LOW < RL1),HIGH,REF(HIGH,BARSLAST((LOW < RL1))));

RL42:=IF((LOW < RL1),J,REF(J,BARSLAST((LOW < RL1))));

RL5:=IF((((LOW < RL4) AND (J > RL42)) AND (J > J24)),LOW,REF(LOW,BARSLAST((((LOW < RL4) AND (J > RL42)) AND (J > J24)))));

CB:=((AMOUNT / VOL) / 100);

CD:=((CB > HIGH) OR (CB < LOW));

黑马趋势:=MA(CLOSE,3);

AA10:=MA(CLOSE,8);

DRAWTEXT(FILTER(((((((CLOSE / OPEN) > 1.04) AND ((CLOSE - REF(CLOSE,1)) > 0)) AND (CLOSE > 下轨道)) AND ((AA10 - REF(AA10,1)) > 0)) AND (CLOSE < 上)),3),(LOW - 0.05),'▲追'),color00ff00;

短期底部:=LLV(OPEN,30);

DRAWTEXT(((((((CROSS(黑马趋势,短期底部) AND ((RL5 - REF(RL5,1)) > 0)) AND ((黑马趋势 - REF(黑马趋势,1)) > 0)) AND (黑马趋势 > 1)) AND (LOW <= 支撑位)) AND (CLOSE > 支撑位)) AND (HIGH < 压力位)),(LOW - 0.15),'←黑马发现'),colorFF00FF;

DRAWTEXT((((((((CROSS(黑马趋势,RL5) AND ((黑马趋势 - REF(黑马趋势,1)) > 0)) AND (HIGH < 压力位)) AND (LOW <= 短期底部)) AND (CLOSE > 支撑位)) AND (CD < 1)) AND (CLOSE > OPEN)) AND (CLOSE > RL5)),LOW,'←短买'),colorBLUE;

VAR5:=(((HHV(HIGH,36) - CLOSE) / (HHV(HIGH,36) - LLV(LOW,36))) * 100);

VAR6:=SMA(VAR5,5,1);

VAR7:=SMA(VAR6,8,1);

VAR8:=(CROSS(VAR6,VAR7) AND (VAR7 < 16));

VAR9:=((CLOSE > (LLV(CLOSE,60) + (0.3 * LLV(CLOSE,60)))) AND VAR8);

VARA:=IF((CLOSE > 1000),VAR8,VAR9);

逃遁:=VARA;

DRAWTEXT(VARA,HIGH+0.06,'▼逃遁'),color006633;

趋势线:=3*SMA((CLOSE-LLV(LOW,28))/(HHV(HIGH,28)-LLV(LOW,28))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);

底部:=LLV(CLOSE,30);

ma3:=MA(底部,2);

x:=MA(CLOSE,26);

压力:=HHV(HIGH,30);

DRAWTEXT(FILTER(LOW<=x and CLOSE>=x and ma3>=REF(ma3,1)and CLOSE/OPEN>1.02 and WINNER(CLOSE)<0.4,20),c*0.9285,'看多'),color993399;

DRAWTEXT(FILTER(HIGH>=压力 and CLOSE<HIGH and CLOSE<OPEN and OPEN/CLOSE>1.03 and WINNER(CLOSE)>0.6,5),HIGH + 0.06,'压力'),colorgreen;

短期乖离率:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;

DRAWTEXT(FILTER(IF(CROSS(趋势线,10)and CLOSE/LOW>1.04 and 短期乖离率<0.35 ,1,0)and CLOSE>OPEN,5),LOW-0.07,'底'),COLORRED;

{**********************************};历史大底:DRAWTEXT(FILTER((((((LLV(LOW,0) AND (WINNER(CLOSE) < 0.08)) AND (LOW <= 短期底部)) AND (CLOSE > 短期底部)) AND (J < 80)) AND ((CLOSE / OPEN) > 1.08)),20),(LOW - 0.288),'★★历史大底');

cj2:=DMA(EMA(CLOSE,12),SUM(VOL,5)/3/CAPITAL);

cj3:=(CLOSE-cj2)/cj2*100;

cj4:=REF(cj3,1)<-40 AND cj3>REF(cj3,1) AND REF(cj3,1)<REF(cj3,2) AND cj3-REF(cj3,1)>2.5;

cj5:=(CLOSE-OPEN)/OPEN*100;

cj6:=REF(CLOSE,1);

cj7:=SMA(MAX(CLOSE-cj6,0),6,1)/SMA(ABS(CLOSE-cj6),6,1)*100;

cj8:=COUNT(cj7<20,20)>=1;

cj9:=cj5>9 AND cj8;

cjA:=100*WINNER(OPEN);

cjB:=100*WINNER(CLOSE);

cjC:=cjB-cjA;

cjD:=cjC>=30;

cjE:=CLOSE/MA(CLOSE,3)>=1.07 AND CLOSE=HHV(CLOSE,3) AND MA(VOL,2)/MA(VOL,40)>=3 AND MA(VOL,2)=HHV(MA(VOL,2),3) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);

cjF:=REF(CLOSE,1);

cj10:=SMA(MAX(CLOSE-cjF,0),5,1)/SMA(ABS(CLOSE-cjF),5,1)*100;

cj11:=COUNT(cj10<20,20)>=1;

cj12:=cjE AND cj11;

cj13:=MA(CLOSE,4);

cj14:=MA(CLOSE,10);

cj15:=MA(CLOSE,20);

cj16:=MA(CLOSE,25);

cj17:=COUNT(CROSS(cj14,cj15),2)=1;

cj18:=COUNT(CROSS(cj13,cj16),2)=1;

cj19:=cj17 AND cj18;

cj1A:=cj12 AND cjD AND cj19;

cj1B:=MA(CLOSE,80)-MA(CLOSE,10)/3;

cj1C:=CLOSE<cj1B AND VOL/240>MA(VOL,5)/240 AND CLOSE>REF(CLOSE,1)*1.08 AND CLOSE<MA(CLOSE,13)*1.3;

短底反弹:=cj4 OR cj9 OR cj1A OR cj1C;

ls:=c/ref(c,1)>1.048 and c=h and between(forcast(V,4),0.2*forcast(v,12),2.1*forcast(v,12));

拉升:=filter(ls,28)*100;

DRAWTEXT(短底反弹,low*0.978,'●短底'),linethick1,{colorffffff}colorff00ff;

{捉妖记} {主图指标}

{VAR4:=(((((REF(C,1)) * (1.1)) - C) < (0.01)) AND (H = C));

E5:=(EMA(C,5));

VAR5:=((20 * H + 19 * (REF(H,1)) + 18 * (REF(H,2)) + 17 * (REF(H,3)) + 16 * (REF(H,4)) + 15 * (REF(H,5)) + 14 * (REF(H,6)) + 13 * (REF(H,7)) + 12 * (REF(H,8)) + 11 * (REF(H,9)) + 10 * (REF(H,10)) + 9 * (REF(H,11)) + 8 * (REF(H,12)) + 7 * (REF(H,13)) + 6 * (REF(H,14)) + 5 * (REF(H,15)) + 4 * (REF(H,16)) + 3 * (REF(H,17)) + 2 * (REF(H,18)) + REF(H,20)) / (210));

VAR6:=(EMA(VAR5,90));

妖股线:(VAR6 + (((C - (VAR6)) * C) - (VAR6)) / (VAR6)),LINETHICK2,colorFF00FF;

VAR8:=(CROSS(妖股线,E5));

DRAWTEXT((VAR8) AND (VAR4),L,'↖超级主升'),LINETHICK3,COLORRED;};



 

点击下载大智慧公式调试用软件>>
赞赏本站
联系客服:
客服
返回课程列表