股票教程网

大智慧L2资金流向指标公式

Class:大智慧公式 Time:2017-8-21 Hits:2872

股票教程网,http://www.91goo.com,友情提供

{☆背景设置}

DRAWGBKLAST(v>1,STRIP(RGB(00,0,0),RGB(90,90,90),0));


{☆资金流向}

{//——————【参数定义】}

ZLCM:=EMA(WINNER(CLOSE)*70,3);{//主力筹码估算}

SHCM:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3);{//散户筹码估算}

ZSHTL:=SHCM/(ZLCM+SHCM)*100;{//散户套牢筹码比率}

ZZLKP:=ZLCM/(ZLCM+SHCM)*100;{//主力控盘筹码比率}

ZCMZL:=MA(ZLCM+SHCM,13);{//市场筹码总量}

ZZNTS:=BARSLAST(ZSHTL<90 AND REF(ZSHTL,1)>90);{//走牛天数}

ZSHJJ:=EMA(ZSHTL,89);{//散户警戒}

ZZLJJ:=EMA(ZZLKP,89);{//主力警戒}

ZJLRQD:=INTPART(ZZLKP-ZZLJJ);{//资金流入强度}

SH8:=EMA(ZSHTL,8);

DKB:=IF(ZZLKP-REF(ZZLKP,1)>ZSHTL-REF(ZSHTL,1),1,0);


{//——————【数值显示】}

散户套牢系数:INTPART(ZSHTL),LINETHICK0,COLORWHITE;

主力控盘系数:INTPART(ZZLKP),LINETHICK0,COLORCYAN;

资金流入强度:ZJLRQD,LINETHICK0,COLORRED;

市场筹码总量:INTPART(ZCMZL),LINETHICK0,COLORGREEN;


{//——————【图解模板】}

{神秘黑洞}

FILLRGN(ZSHTL,0,REF(ZSHTL,1)>90 AND ZSHTL<90),COLOR9966FF;

{散户套牢筹码}

STICKLINE(C>0,ZSHTL,ZZLKP,0,0),COLOREEEEEE;

{散户筹码警戒}

STICKLINE(ZSHJJ>REF(ZSHJJ,1),ZSHTL,ZSHJJ,1,0),COLORaaaaaa;

{散户线}

PARTLINE(ZSHTL,C>0),POINTDOT,COLORYELLOW;

{主力控盘筹码}

STICKLINE(C>0,ZZLKP,0,7,0),COLORBLUE;

{铸顶风险区}

STICKLINE(ZZLKP>75,ZZLKP,0,7,0),COLORFFFFFF;

{主力筹码警戒}

STICKLINE(ZZLJJ>REF(ZZLJJ,1),ZZLKP,ZZLJJ,7,0),COLORRED;

{筑底散兵坑}

STICKLINE(ZSHTL>=90,ZZLKP,0,7,0),COLOR66FFCC;

{筹码总量}

PARTLINE(ZCMZL,C>0),COLORGREEN;

{筹码总量上升}

PARTLINE(ZCMZL,ZCMZL>REF(ZCMZL,1)),COLOR0066FF;

{增量资金}

DRAWTEXT(ZCMZL>REF(ZCMZL,1) AND SH8<REF(SH8,1) AND BARSTATUS=2,ZCMZL,'←增量资金');

{//------【解盘分析】}

TJTS:=BARSTATUS=2;

DRAWTEXT(TJTS and C>0,130,'资金流向分析 '),LINETHICK6,Coloryellow,ALIGN2;

DRAWTEXT(TJTS and C>0,130,' '+STKLABEL+' '+STKNAME+' '),LINETHICK6,ColorFFFF80,ALIGN2;

DRAWTEXT(TJTS and C>0,128,' '+ '走牛天数判断:'+' '+NUMTOSTRN( ZZNTS,0 )+' '),LINETHICK3,ColorFFFF80,ALIGN2;

{主力动向监控}

DRAWTEXT(TJTS and ZCMZL>REF(ZCMZL,1) AND DKB=1,110,'主力动向监控:主力增仓 '),COLORRED,ALIGN2;

DRAWTEXT(TJTS and ZCMZL>REF(ZCMZL,1) AND DKB=0,110,'主力动向监控:主力减仓 '),COLORMAGENTA,ALIGN2;

DRAWTEXT(TJTS and ZCMZL=REF(ZCMZL,1),110,'主力动向监控:多空平衡 '),COLORGRAY,ALIGN2;

DRAWTEXT(TJTS and ZCMZL<REF(ZCMZL,1) AND DKB=1,110,'主力动向监控:主力回补 '),COLORFF9933,ALIGN2;

DRAWTEXT(TJTS and ZCMZL<REF(ZCMZL,1) AND DKB=0,110,'主力动向监控:主力出逃 '),COLORGREEN,ALIGN2;

{特别信号提示}

DRAWTEXT(TJTS and ZSHTL>90,100,'特别信号提示:筑底散兵坑 '),COLOR66FFCC,ALIGN2;

DRAWTEXT(TJTS and ZZLKP>75,100,'特别信号提示:铸顶风险区 '),COLORCYAN,ALIGN2;

DRAWTEXT(TJTS and CROSS(ZCMZL,ZZLJJ) AND ZZLKP>ZZLJJ AND ZZLKP>10 AND ZZLJJ>REF(ZZLJJ,1) AND ZCMZL>REF(ZCMZL,1),100,'特别信号提示:穿越主力 '),COLORRED,ALIGN2;

DRAWTEXT(TJTS and CROSS(ZCMZL,ZZLKP) AND ZZLKP>ZZLJJ AND ZZLKP<ZSHTL AND ZZLKP>10 AND ZZLJJ>REF(ZZLJJ,1) AND ZCMZL>REF(ZCMZL,1),100,'特别信号提示:穿越主力 '),COLORYELLOW,ALIGN2;

DRAWTEXT(TJTS and CROSS(ZCMZL,ZSHTL) AND ZSHTL>ZZLKP AND ZCMZL>REF(ZCMZL,1),100,'特别信号提示:穿越散户 '),COLORGREEN,ALIGN2;

DRAWTEXT(TJTS and CROSS(ZCMZL,100) AND ZCMZL>REF(ZCMZL,1),100,'特别信号提示:全盘穿越 '),COLOR3399FF,ALIGN2;

DRAWTEXT(TJTS and REF(ZSHTL,1)>90 AND ZSHTL<90,100,'特别信号提示:神秘黑洞 '),COLOR9966FF,ALIGN2;


 


{☆背景设置}

{DRAWGBK(C=C,COLORRGB(130,130,130),COLORRGB(30,30,30),1);}

DRAWGBKLAST(v>1,STRIP(RGB(130,130,130),RGB(30,30,30),0));

{☆精确风险}

{//------【参数定义】}

RSV:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;

K1:=SMA(RSV,10,1);

D1:=SMA(K1,5,1);

KK:=INTPART(K1);

DD:=INTPART(D1);

TFXXS:=KK+DD;{//变异KD风险系数}

TGLD:=MOD(TFXXS,10);{//踏浪涨停概率点}

TGLXS:=(TFXXS-REF(TFXXS,1))*10;{//变异KD乖离系数}

TYCFX:=TFXXS+TGLXS;{//变异KD预测风险}


{//------【数值显示】}

风险系数:TFXXS,LINETHICK0,COLORYELLOW;

乖离系数:TGLXS,LINETHICK0,COLORGREEN;

预测风险:TYCFX,LINETHICK0,COLORCYAN;


{//------【图解模板】}

{级别拐点}

VERTLINE(TGLXS>0 AND 100+TGLXS<TYCFX AND 100+REF(TGLXS,1)>=REF(TYCFX,1),1),COLORYELLOW;

VERTLINE(TGLXS<0 AND 100+TGLXS>=TYCFX AND 100+REF(TGLXS,1)<REF(TYCFX,1),1),COLORYELLOW;

{乖离系数}

STICKLINE(TGLXS>0,100,100+TGLXS,8,0),COLOR000088;

STICKLINE(TGLXS>0,100,100+TGLXS,7,0),COLOR000099;

STICKLINE(TGLXS>0,100,100+TGLXS,6,0),COLOR0000AA;

STICKLINE(TGLXS>0,100,100+TGLXS,5,0),COLOR0000BB;

STICKLINE(TGLXS>0,100,100+TGLXS,4,0),COLOR0000CC;

STICKLINE(TGLXS>0,100,100+TGLXS,3,0),COLOR0000DD;

STICKLINE(TGLXS>0,100,100+TGLXS,2,0),COLOR0000EE;

STICKLINE(TGLXS>0,100,100+TGLXS,1,0),COLOR0000FF;{//红柱}

STICKLINE(TGLXS<0,100,100+TGLXS,8,0),COLOR008800;

STICKLINE(TGLXS<0,100,100+TGLXS,7,0),COLOR009900;

STICKLINE(TGLXS<0,100,100+TGLXS,6,0),COLOR00AA00;

STICKLINE(TGLXS<0,100,100+TGLXS,5,0),COLOR00BB00;

STICKLINE(TGLXS<0,100,100+TGLXS,4,0),COLOR00CC00;

STICKLINE(TGLXS<0,100,100+TGLXS,3,0),COLOR00DD00;

STICKLINE(TGLXS<0,100,100+TGLXS,2,0),COLOR00EE00;

STICKLINE(TGLXS<0,100,100+TGLXS,1,0),COLOR00FF00;{//绿柱}

STICKLINE(TGLXS=0 AND REF(TGLXS,1)>=0,100,100+TGLXS,8,0),COLORRED;

STICKLINE(TGLXS=0 AND REF(TGLXS,1)<0,100,100+TGLXS,8,0),COLORGREEN;

{风险系数}

PARTLINE(TFXXS,TFXXS<160 AND TFXXS>50),LINETHICK2,COLORFF66FF;

PARTLINE(TFXXS,TFXXS>50 AND TFXXS<160 AND TFXXS<REF(TFXXS,1)),LINETHICK2,COLORWHITE;

PARTLINE(TFXXS,TFXXS<=50),LINETHICK2,COLORYELLOW;

PARTLINE(TFXXS,TFXXS>=160),LINETHICK2,COLORBLUE;

{预测风险}

PARTLINE(TYCFX,C>0),COLORCYAN;


{//------【解盘分析】}

DRAWTEXT(BARSTATUS=2 and TFXXS<=50,50,'操作风险提示:买入风险'),COLORYELLOW,ALIGN2;

DRAWTEXT(BARSTATUS=2 and TFXXS>=160,50,'操作风险提示:卖出风险'),COLORCYAN,ALIGN2;

DRAWTEXT(BARSTATUS=2 and TFXXS>50 AND TFXXS<160 AND TFXXS>=REF(TFXXS,1) AND TFXXS<=100,50,'操作风险提示:追涨博弈'),COLORRED,ALIGN2;

DRAWTEXT(BARSTATUS=2 and TFXXS>50 AND TFXXS<160 AND TFXXS>=REF(TFXXS,1) AND TFXXS>100,50,'操作风险提示:稳健持股'),COLORMAGENTA,ALIGN2;

DRAWTEXT(BARSTATUS=2 and TFXXS>50 AND TFXXS<160 AND TFXXS<REF(TFXXS,1) AND TFXXS>100,50,'操作风险提示:盘跌减仓'),COLORWHITE,ALIGN2;

DRAWTEXT(BARSTATUS=2 and TFXXS>50 AND TFXXS<160 AND TFXXS<REF(TFXXS,1) AND TFXXS<=100,50,'操作风险提示:杀跌空仓'),COLORGREEN,ALIGN2;



 

股票教程网所有股票公式,仅供学习研究,只有参考价值,请勿以此为依据进行股票交易!

本站所有公式全部免费,如果这条公式对您有价值,或有帮助,请打开微信,扫一扫下面的二维码,赞助本站,金额随意!

感谢您对支持我们的发展和对我们工作的肯定!小编在些表示感谢!

本站提供通达信选股公式,看盘主图副图指标,编写,修改,DLL加密等业务,详询客服!