教育巴巴炒股教程网

通达信缠论笔分型副图指标公式

Class:通达信公式 Time:2020-10-26 Hits:469

通达信缠论笔分型副图指标公式
KX:='CHANLUN@KXIAN';
KXG:='CHANLUN@KXG';
KXD:='CHANLUN@KXD';
KXFX:='CHANLUN@KXFX';
笔:='CHANLUN@BI';
BILAST:='CHANLUN@BILAST';
段:='CHANLUN@DUAN';
DUANLAST:='CHANLUN@DUANLAST';
中枢:='CHANLUN@ZS';
ZSZG:='CHANLUN@ZSZG';
ZSZD:='CHANLUN@ZSZD';
ZSGG:='CHANLUN@ZSGG';
ZSDD:='CHANLUN@ZSDD';
ZSZZ:='CHANLUN@ZSZZ';
ZSKS:='CHANLUN@ZSKSLAST';
ZSJS:='CHANLUN@ZSJSLAST';
BIFX:=-REF(笔,BILAST);
DUANFX:=-REF(段,DUANLAST);
KXQJ:='CHANLUN@KXQJ';
STICKLINE(ZSZG>ZSZD AND DUANFX=1, ZSZG, ZSZD, 10, 1),COLOR8E236B;
STICKLINE(ZSZG>ZSZD AND DUANFX=-1, ZSZG, ZSZD, 10, 1), COLOR007700;
DRAWLINE(ZSKS=1, ZSZZ, ZSJS=1, ZSZZ, 0), COLORFFFFFF;
STICKLINE(KX>0, KXG, KXD, 5, 1),COLOR007700,LINETHICK2;
STICKLINE(KX<0, KXG, KXD, 5, 1),COLOR00FFFF,LINETHICK2;
STICKLINE(笔=1, KXG, KXD, 5, 1), colorgreen, LINETHICK2;
STICKLINE(笔=-1, KXG, KXD, 5, 1), colorred, LINETHICK2;
STICKLINE(段=1, KXG, KXD, 5, 0), COLOR007700, LINETHICK2;
STICKLINE(段=-1, KXG, KXD, 5, 0), COLOR0000CC, LINETHICK2;
DRAWLINE(笔=1,H,笔=-1,L,0),colorblue,LINETHICK2;
DRAWLINE(笔=-1,L,笔=1,H,0),COLORFF00FF ,LINETHICK2;
DRAWLINE(段=1,H,段=-1,L,0),COLOR007700, LINETHICK2;
DRAWLINE(段=-1,L,段=1,H,0),colorred, LINETHICK2;
DRAWTEXT(笔= 1, H*1.038, ''+H+''), COLORFFFFFF;
DRAWTEXT(笔=-1, L*0.96, ''+L+''), COLORFFFFFF;
VAR3:=LLV(H,240);
VAR4:=100*(C-VAR3)/VAR3;
VAR5:=(C-LLV(L,528))/(HHV(H,528)-LLV(L,528))*100;
VAR6:=(C-LLV(C,530))/(HHV(C,530)-LLV(C,530))*100;
VAR7:=0;
VAR8:=SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100;
VAR9:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100;
VAR10:=IF(TROUGHBARS(3,16,1)=0 AND H>L+0.04,4,0);
VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
VAR12:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
VAR14:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
VAR16:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
VAR18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
VAR19:=EMA(C,2)-EMA(C,150);
买1:=VAR10;
买2:=(VAR11+VAR13+VAR15+VAR17);
卖1:=(VAR12+VAR14+VAR16+VAR18);
DRAWTEXT(买1>0 OR 买2>0,L*0.985,'买'),COLOR00FFFF;
DRAWTEXT(卖1>0,H*1.01,'卖'),COLOR00FFFF;
APP:=(VOL)/((H-L)*(2)-ABS(C-O));
ZL:=IF((H>O),(APP)*(H-L),IF((L<O),(APP)*(H-O+C-L),(VOL)/(2)));
SF:=IF((H>O),0-(APP)*(H-C+O-L),IF((L<O),0-(APP)*(H-L),0-(VOL)/(2)));
库存能量:=MA(ZL+SF,2);
库存平均:=MA(ZL+SF,5);
GET:ZIG(3,5),coloryellow,LINETHICK3;
PL5:=ZIG(3,5);
EN1:=PL5>REF(PL5,1) AND REF(PL5,1)<=REF(PL5,2) AND REF(PL5,2)<=REF(PL5,3);
EX1:=PL5<REF(PL5,1) AND REF(PL5,1)>=REF(PL5,2) AND REF(PL5,2)>=REF(PL5,3);
PL10:=ZIG(3,10);
EN2:=PL10>REF(PL10,1) AND REF(PL10,1)<=REF(PL10,2) AND REF(PL10,2)<=REF(PL10,3);
EX2:=PL10<REF(PL10,1) AND REF(PL10,1)>=REF(PL10,2) AND REF(PL10,2)>=REF(PL10,3);
PL20:=ZIG(3,20);
EN3:=PL20>REF(PL20,1) AND REF(PL20,1)<=REF(PL20,2) AND REF(PL20,2)<=REF(PL20,3);
EX3:=PL20<REF(PL20,1) AND REF(PL20,1)>=REF(PL20,2) AND REF(PL20,2)>=REF(PL20,3);
走强1:=BARSLAST(PL5<REF(PL5,1));
走弱1:=BARSLAST(PL5>REF(PL5,1));
走强2:=BARSLAST(PL10<REF(PL10,1));
走弱2:=BARSLAST(PL10>REF(PL10,1));
走强3:=BARSLAST(PL20<REF(PL20,1));
走弱3:=BARSLAST(PL20>REF(PL20,1));
ZTJZ5:=IF(PL10>REF(PL10,1),COUNT(EN1,走强2),0);
ZTJD5:=IF(PL10>REF(PL10,1),COUNT(EX1,走强2),0);
DTJZ5:=IF(PL10<REF(PL10,1),COUNT(EN1,走弱2),0);
DTJD5:=IF(PL10<REF(PL10,1),COUNT(EX1,走弱2),0);
ZTJZ10:=IF(PL20>REF(PL20,1),COUNT(EN2,走强3),0);
ZTJD10:=IF(PL20>REF(PL20,1),COUNT(EX2,走强3),0);
DTJZ10:=IF(PL20<REF(PL20,1),COUNT(EN2,走弱3),0);
DTJD10:=IF(PL20<REF(PL20,1),COUNT(EX2,走弱3),0);
DRAWTEXT(EN2 AND DTJZ10=1,L*0.93,'[类二买]'),COLORFFFFFF;
DRAWTEXT(EN3 AND ZTJZ10=1,L*0.95,'[一买]'),COLORFF00FF;
DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=1,H*1.05,'[二卖]'),LINETHICK2,COLORFFFF00;
DRAWTEXT(EN2 AND PL20>REF(PL20,1) AND ZTJZ10=2,L*0.95,'[二买]'),LINETHICK2,COLORFFFF00;
DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=2 OR (ZTJD10=0 OR ZTJD10=2) AND EX2,H*1.04,'[一卖]'),LINETHICK3,COLOR00FF00;
MA5:MA(CLOSE,5),colorwhite,LINETHICK1;
MA10:MA(CLOSE,10),colorgreen,LINETHICK1;
MA24:MA(CLOSE,24),colorred,LINETHICK1;
趋势:ZIG(3,5);
向上:=CROSS(趋势,REF(趋势,1));
向下:=CROSS(REF(趋势,1),趋势);
上1周期:=SUMBARS(向上,1);
上2周期:=SUMBARS(向上,2);
上3周期:=SUMBARS(向上,3);
下1周期:=SUMBARS(向下,1);
下2周期:=SUMBARS(向下,2);
下3周期:=SUMBARS(向下,3);
A1:=REF(趋势,下1周期);
A2:=REF(趋势,下2周期);
高点重叠:=MIN(A1,A2);
低点重叠:=MAX(REF(趋势,上1周期),REF(趋势,上2周期));
高点:=(趋势=高点重叠);
连线1:=BARSLAST(高点)>上1周期 OR BARSLAST(高点)>下1周期;
连线2:=BARSLAST(高点)<上2周期 OR BARSLAST(高点)<下2周期;
低点:=(趋势=低点重叠);
高1:=SUMBARS(高点,1);
高2:=SUMBARS(高点,2);
低1:=SUMBARS(低点,1);
低2:=SUMBARS(低点,2);
DRAWTEXT(C,高点重叠,'_____');
DRAWTEXT(C,低点重叠,'_____');

image.png

{教育巴巴炒股教程网,http://9188edu.com,友情提供}
股票教程网所有股票公式,仅供学习研究,只有参考价值,请勿以此为依据进行股票交易!

本站所有公式全部免费,如果这条公式对您有价值,或有帮助,请打开微信,扫一扫下面的二维码,赞助本站,金额随意!

感谢您对支持我们的发展和对我们工作的肯定!小编在些表示感谢!

本站提供通达信选股公式,看盘主图副图指标,编写,修改,DLL加密等业务,详询客服!